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Welcome to Your Creative Mentor.  Here is a little how-to-guide I wrote for young people beginning their 3D 
Animation careers using Blender 3D.  A wonderful advancement is how similar Blender is to regular production house 
tools.  If you learn Blender, and the principles above the software well, you shouldn’t have a problem landing a dream 
project of your choice.  With that a bid you happy Animating and may the creativity keep a’flowing. 

Yours Truly,  
Matthew Vogt 

 (Matthew@YourCreativeMentor.com) 

The Universal Beginner’s Section: 
Getting Stuck?  Don’t know what to do?  Don’t ask your teacher or your parents – ask Google!  Matter of fact, the better 
you are at independent problem solving, the farther you’ll reach!  The amount of times I was stuck writing these pages…. 
phew, Google saved my life.  Granted, sometimes it helps and can be quicker to ask people who’ve gone before you but 
when you can’t (like if you’re animating at home and you don’t Matthew in the same room) you’re going have to charge 
ahead yourself – this is the greatest form of practice you can do in Computer Animation 

“HELP!!” – Yes, practically every piece of software in this universe comes with a help feature.  Even Blender, even MS 
Word, even Windows Explorer.  Use these to find what you need; amazingly, you can search them too. To use Help in 
Blender, click Help > Manual (most useful!) or try Help> User Community etc. Remember, don’t forget to search them! 
You will find the hardest part of learning new amazing things is ‘terming’ what you don’t know.  Just giver. 

Tool Tips – Oh look! Not sure what that Interpolating Augmented Particle Simulation Button does? Do not worry! Tool 
tips appear for practically every button in software these days, all you have to do is patiently hover your mouse over a 
function and behold!  A tool-tip bubble will appear solving such a mystery! 

Shortcuts? Two hands - working efficiently on the computer requires the grace of a concert pianist.  What this means is 
you need your workspace to enable you to always have a hand on the mouse and a hand on the keyboard.  Statistically 
speaking,  moving the mouse and clicking a menu entry isn’t as fast as using Ctrl + S to save your file or whatever. Are 
these power combos only accessible to the master computer veterans?  No – you can find shortcuts to your most 
commonly used commands by either doing the Tool-Tip-Hover, finding them in the menu listings, or even the help 
documentation.  Use them well my friends.  Menus are most informative for these. Note, this doc is for Windows. 

Ctrl + Z = Undo last actions – good for accidents! 

Save Before Closing? Blender doesn’t ask to “Save Changes Before Exiting” – Be Aware, Save with Care.   

Save Incrementally! With all important computer work you do, never just go Ctrl + S to save.  This will overwrite the 
work you have previously done.  Instead use Save-As each time you want to preserve your work and add a greater, or 
incremental number on the end.  For example I start a robot scene and call it MattsRobot01.blend.  Just did some 
awesome changes, it’s time to save-as and call it MattsRobot02.blend.  With complicated computer works, you can 
change something without knowing the consequence – this will protect your work.  Note, this is extremely useful when 
moving files and folders around, you can never replace a same named file and loose work because every development 
exists independently. 
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Blender 2.5  Preflight Setup: 
Blender is a free, open source 3D Animation program.  These notes pertain to version 2.5.  You can find Blender 
downloads for either MAC, Windows or Linux at http://blender.org These documents were written when version 2.5 
was still in development.  You can find the newest “builds” at http://www.graphicall.org/builds/ That’s the beauty of 
Open Source Software, it’s continually getting better and better – for free.  I recommend looking for the latest version at 
that Graphicall website.  Matter of fact, version 2.54 is available from blender.org – we’ll use that now. 

Blender is usually packaged in a compressed ZIP file.  You simply extract it somewhere, say in a folder called “Blender25-
29996” or whatever.   

 

(Hot Tip) You can create a shortcut for Blender on your Desktop by using the Right Click (RMB) drag and drop – choose 
Create Shortcut. Insta-User-Interface Customization!   

Once Blender’s open. Congratulate yourself because a world of opportunity has just presented itself.  First things first, 
you’ll have to follow these directions to change some settings and save them.  What we do next is to configure Blender 
so it’s more friendly for us to use.   

http://blender.org/�
http://www.graphicall.org/builds/�
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 To change our settings click File > User Preferences (Ctrl + Alt + U) (shortcuts are our friends!) in Blender 

Under the Interface Tab – Turn on Manipulator, with the check box 

Editing – Top left, you want to Link Materials to Objects. 

Input – Select with “Left” mouse button, Orbit Style “Turn Table”  - Check Emulate Numpad (if using a laptop) 

File Tab –Make sure Relative Paths  is checked  

Done and Done?  Now simply hit “Save as Default” and we’re ready to go!  The nice thing about saving our default 
settings is that whenever we freshly start Blender, our settings will be remembered.  Do these things for your home 
studio as well – nothing’s better than having a creative space set just the way you want it! 

 

Introduction 
The User Interface aka UI: 

Blender has a liquid user interface meaning you can add as many viewing windows, property panels, you name it!  Every 
area is called a panel and you can adjust the size, the content, the location and the divisions of them all.  
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(above – the standard 2.5 UI, breathtaking) 

Introduction to your new workspace!  Your creative station! 

• 3D View:  Otherwise known as a viewport, this is your window to your working world.  Everything appears and 
can be changed in this panel.   

o Tool Shelf (shortcut = T) part of the 3D View.  You can find it under the view menu in your 3D view. 

o Properties (shortcut = N) 

• Timeline:  Where animation begins!  More on this later. 

• Outline:  This is to outline all the objects and ‘stuff’ you may have in your scene.  You can lock things, to be un-
selectable, you can hide things and you can simply select things by their name.  Every time you add something to 
your scene, or stage, I highly recommend you name it something proper so you stay organized and don’t loose 
time figuring out what is what!  Also, advanced operations can be jeopardized with naming conflicts – be aware! 

• Property Tabs:  We’ll dive into these many times, this is where a lot of settings are found.  Sometimes, the 
property tabs will change depending on what you have selected, in other words different ‘stuff’ has different 
‘stuff’ pertaining to it.   

Using the Liquid UI:  Every panel has those diagonal lines in the bottom left corner and top right corner.  You have to 
position your mouse perfectly on them and your pointer cursor will change to a little plus sign.  Click and drag that plus 
sign to add another panel.  You can combine panels by dragging that plus sign towards other panels!  That’s why there’s 
two on each corner so you can either add or dissolve panels horizontally or vertically!  Enjoy the fluidness! 

3D Virtual Reality? It is possible with computers.  Think of a graph, or grid – you have two directions, across (X) and up 
and down (Y).   Blender’s space has another one called Z .  It’s like three grids, planes, dimensions in one!   
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(Hot Tip) It’s great to remember XYZ and which way they are in Blender by the colors.  X is Red, Y is Green and Z is Blue 
or XYZ=RGB ! 

For the most boiled down computer science possible:  we can plot points on a graph like point A is (X= 3, Y = 5) for it’s 
position.  In 3D space we have points with three coordinates , for example(X= 3, Y = 5, Z = 7) taadaa! That point would 
now exists in 3D space.  We can make a triangle by having three located points, or we could complicate it and make a 
cube with 8 points, 4 on top of each other all connected to make 6 sides!  Don’t worry science is easy once experienced 
firsthand!!  

3D Computer Graphics Terminology / Object Classes 

Understanding the broad terms or categories of computer animation allows for stronger focus in specific theories.  
Matter of fact, 10 years ago every 3D artist knew everything about computer graphics  - they had to.  Now, you find 
studios (Vancouver Game studios/Hollywood VFX studios etc) looking for very specific roles or expertise such as a 
character animator, an environment modeler, a scene lighter, render artist, character rigger – gosh, big titles for such 
specific things.  Don’t get bogged down just yet!  It’s very important to embrace your learning at this broad level because 
the more you know about the interrelation of the foundations, the more awareness you bring to your team and tasks at 
hand.  Enjoy!!!  You will find lifetimes of artist and creative theory for each and every group, online – modeling and 
topology theory, character animation theory, lighting/colour theory etc .  Jack of all / Master of none?  Look to the 
masters in the specific areas to see what’s developed over time!  Normally you find the greatest quality of work with 
people who focus primarily in one area of another (although they’d be useless making a film by themselves). 
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The general areas: 

These areas/titles popup all over the industry be it VFX, Film or Video Games. 

Modeling:  A ‘Model’ is an object in 3D space.  Geometry or a mesh is another term for these objects.  When you 
‘Model’ something you actually create it or sculpt it.  You now can go on forums and say “Hey, nice Model!  I like how 
you Modeled the fins of the rocket!” Proportion, silhouette, weight/balance, shape, anatomy are all included here! 

Texturing:  A Texture Artist is one who paints the surface of a model to give it a real world diffuse.  ‘Diffuse’ is the 
surface texture (like colour), specular is the shine, reflection, bump etc etc all add up to the material we give our models.  
Would it be skin with sub-surface-scattering (sss) which allows for light to pass through (translucency) like an ear for 
example?  Ever hold a flash light up to your fingers and they turn red?  Materials can do that in 3D for us!  Does your 
robot have a shiny paint job?  Does your woman have glowing skin?  Does your race car have decal sponsors?  All of this 
is addressed through texturing and subsequently, object materials. 

Rigging:  Rigging is the task of adding a skeleton, rig or animation controls to a model or geometry.  Normally rigging 
occurs once the model is completed and it’s time to give it manipulative abilities.  Bones are an object class in 3D. Bones 
control the geometry and animation controls effect those bones! A TD, or technical director is normally in charge of this 
task at a studio.   

Animation: Taking a rig, or your animation controls, you breathe life to your static objects.  Giving something life is no 
easy feat but a challenge worth fighting for! Animators are considered the visual storytellers of our day. 

Lighting: In 3D we do have lights!  Profession Lighters, be it film or game etc are considered the ones who “paint with 
light”. The abilities of lighting in 3D are just as vast as the other areas.  Sun light?  Cast shadows?  Light bounces?  Light 
colors?  Glow? Light Attenuation (fall off distance)?  Light intensity?  3 point lighting setups?  All of these are standard 
language for lighting!  (bring sun screen) 

Rendering: Take my picture? Rendering or a render artist takes the 3D working scene in your program, like Blender’s, 
and produces high quality stills or images from it.  It’s a way of collecting all the work and content of a 3D scene and 
producing a high quality render.  You can render still images like a 3D kitchen interior – including your models 
(cupboards, plates, table, microwave), your textures/materials (shiny metal, wood texture, food grime, reflections) and 
lighting with shadows (sun through the curtains, table lamp and those ugly tube lights) etc.  Rendering and lighting are 
very interrelated.  Not only that! You can also render animation segments, which essentially is a collection of frames 
playing one after another!  A classic line “Nice progress there, let’s see a beauty render.” A beauty render is that which 
our digital artist pulls all the stops to make the most elegant, captivating, believable image with their 3D content. Magic.  

Simulations / Particles: When I first began, this wasn’t even heard of - but so be it now! Particles and simulations allow 
for amazing computer generation effects or motions such as a fluid simulation, wind/smoke/dust forces, deformation 
(crumpling a car), rag-doll (ever have a game character fall down a flight of stairs?),  and even cloth and fur simulations.  
You can model a character, texture it, rig it, animate it, model a shirt and just toss it on top and set it to a soft-body-
simulation and we’ve reached Pixar technology!   We could make a cute furry guy like in Monsters Inc. 
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Object Classes: 
In Blender, the following is how objects and ‘stuff’ Is categorized.  We can create, select and play with all of these until 
your heart’s content.   

• Geometry (Mesh)  

• Surfaces (Curved Powered Geometry) 

• Shapes (Curves, Text ) 

• Cameras 

• Lights 

• Bones/ Armatures 

• Helpers (rigging things etc – more of a catch-all for specific/custom things)  

Name your ‘Stuff’ 

 

Having an object selected, open the Property Tabs panel and choose the Object tab.  From here, you can rename your 
object to something more logical, recognizable and most importantly unique (good for team projects, sometimes two 
cube001’s will overwrite each other).  In general things are sorted alphabetically yet it’s good to name your ‘stuff’ using 
the most broad terms first.  For example, if I found myself in your summer camp now I would name my cube to 
MatthewRobot3HeadEarL.  So my name first, so peeps know it’s mine.  It’s my 3rd Robot character, it’s his head, and 
finally it’s his ear, on the left!  If I went LeftEarHeadRobot3, that wouldn’t sort as nicely and be grouped with the other  
3rd Robot’s head bits!  Phew!   

(Hot-Tip) In general, it’s good not to use funky characters when naming files and scene ‘stuff’.  Also spaces are not 
always supported so it’s best to keep the words together yet separated by Capital Letters – likeThisForExample 
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3D  Navigation 101 
It’s your first day in a whole new world – lets go over how to get around.  First thing to know is how to orbit your view in 
3D space.  To do so,  use the Middle Mouse Button, MMB, which is the button under your mouse’s scroll wheel.  You 
hold down the scroll wheel in the 3D view of Blender to orbit you view around.   

How about panning?  To Pan your view, you do the same, holding down MMB and drag but you also hold down the 
keyboard’s Shift key.  Try it now!   

And finally, zoom zoom!  Use the wheel itself to zoom in and out.   

Orbit, Pan and Zoom – our three friends in viewing things in virtual space.  Learn them well! 

This may be mind blowing, but we need to understand the difference between orthographic and perspective views in 
our 3D view.   

 

As you can see in the above image, the cylinder actually looks 3D in Perspective.  I recommend using Perspective mode 
as much as possible when working in 3D.  The reason for this is that you will see you projects as true to life as possible.  
Orthographical display is good for blueprints etc such as Front, Top Left views etc.  But I would only use Ortho then and 
only then.   

Rant Warning:  Some recommend laying out scenes and adjusting characters in ortho views (“view your character from 
the front and make his face” etc etc).  The more you learn in perspective the better, use perspective to see your object 
in as many ways as possible, see how it looks as you continually orbit and work on your projects. 3D gives us the ability 
to create in 3D and not 2D sides and try to figure it out afterwards.  Another example would be building a car from its 
side view then it’s front view  but the ‘three-quarter’ view will never add up. 

Handy Shortcuts for Navigation: 

MMB  = orbit your camera 
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Shift + MMB = pan your camera 

Wheeling that Scroll Wheel = zoom zoom  your camera 

Number Pad Keys: 

7 = Top View, Ctrl + 7 = Bottom View 

3 = Right View, Ctrl + 3 = Left View 

1 = Front View, Ctrl +1 Back View 

0 = Camera View 

5 = Toggle between Ortho and Perspective – Remember to  ortho only in those blue print views. 

. = This handy shortcut will center our camera right on what we have selected.  When lost, this helps a lot!   

Selections 

LMB Click to select object 

A = Select Nothing aka Deselect and Select All.  Good to start fresh sometimes. This key is used a lot.  

Shift + LMB Add to Selection.  IE:  Select a box, shift select another box to have two boxes selected. 

B Box Selection mode – a handy way to select multiple objects with a rectangular marquee. 

The Amazing 3D View: 

 

You can change the 3D View’s shading to either Textured (with lights), solid (default), wireframe or Bounding Box (which 
is good for very heavy meshes). 

Two handy shortcuts in the 3D View – T and N.  T is for the Tools Panel, where we’ll explore when editing objects 
throughout these lessons.  N used to stand for Numeric Entry but now it produces a panel goodness all around.  In the N 
panel, you can manipulate objects with numbers, very accurate and good to have open to see how your changes read 
out numerically. 
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The classic Quad view: 

Honorable mention here – the quad view is all we had to model in.  It’s a way of breaking up your main viewport into 4 
panels, Top, Front, Right orthos and one perspective view.  You can toggle it to see read silhouette and line things up 
with the shortcut Ctrl + Alt + Q.  You can also find the button under the Display tab in the Numeric Entry panel (N). 

Using your 3D View to your Advantage: 

In addition to centering your view on your selection, via the ‘numpad .’ shortcut (very useful to orbit around your 
specific area of focus), another handy shortcut is Shift + C which will extend your view to everything.  Other programs 
call this View Extends All.  Try it out! 

 

Creating Things! 
You can add things to your scene via the Add menu at the top.  Upon choosing your stuff, they will be created where 
your little red and white cursor is placed.  Explore the Add menu by adding the various things to your scene – these are 
your building blocks – what we all start with! 

(Hot-Tip) You can place your cursor on different things such as the grid centre (origin) or on object faces, edges etc.  To 
do so use the Shift + S to snap them on various things.  This works for ‘edit mode’ selections too (see below… way 
below).  Then when you add something new, it’ll be created on your cursor’s new position. 

(Hot-Tip #2)  You can even move objects to your cursor via Shift + S, using the Selection to Cursor entry. 

(Hot Tip – Advanced) Blender’s pivots are called ‘Object Origins’.  To change a pivot of an object, simply snap the cursor 
to your selection then hit the Origin button in your tool shelf. 

Blender’s Cursor This interesting little target icon is where objects are created in Blender.  You can move it by right 
clicking to place it to your liking.   

 

Transformations 
Transformations in 3D software are simply move, rotate and scale.  These three adjustable things are applied to make 
anything and everything happen!  Move, Rotate and Scale pertain to a selection’s Position, Orientation and Size 
respectively. To begin, if you left click and drag an object in Blender, you move it around in screen space.  The images 
below sum up the difference between “screen space” and global referenced transformations.  The easiest way to 
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transform objects is to use the “gizmo”.  The real name for the gizmo is actually a 3D Manipulator.  The neat thing is the 
gizmo, by default, has both global move arrows and a white circle to grab for screen space tweaks etc. 

Moving things around in screen space, while in perspective is a rapid way to learn 3D navigation as you are required to 
move your view every time you need a new direction.  Screen space is great for tweaking meshes (see edit mode below), 
as you’ll be required to view your model from many different angles as you build it. 

 

 

We can use the gizmo to easily adjust three things on our selections : Location, Orientation and Scale 
(Move/Rotate/Scale) 

In the image above with numbers, you can see that #1 is the mode selector.  Transformations apply to a variety of 
Blender’s modes.  We will be using Object Mode mostly at the start to get the hang of arranging objects in 3D space.  
You can flip on edit mode to dive in to changing objects on a “per sub-object level”. 

#2 is pertaining to which “pivot” or place in space which our object will be transformed around. 

#3 helps us customize our manipulator.  We can have it only show move handles, rotate handles or scale handles.  You 
can hold down shift and select multiple handles at once so you can have rotate and scale ready when needed.  See 
image below for the fully loaded gizmo containing everything! Move on all three axii, screen space move, scale (the box 
ended ones) per axis and rotate per axis and screen rotate!  Coooool. 
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The last part of #3 is called our “Reference Coordinate System”.  What this fancy term does is change the way we 
reference our transformations based on things in our scene.  For example, we can move things in 3D with arrows 
referencing “global” directions, so left right up down etc. – based on the directions of our world, like moving north or 
west etc.  Or we can reference our transformations based on individual objects such as moving an arm down its arm, or 
rotating a wrist around the arm etc.  Very handy.  Another example of reference coordinate handiness is having a rocket 
shoot out at a specific angle and having it accelerate at that angle.  You would use the rocket’s local reference for 
moving it based on where it’s pointing! 

Manipulator Tips: 

Shift Click an Axis to use the other 2 at the same time, ie 2D transformations.  You can arrange your living room by shift 
clicking the Z axis thus moving furniture around constrained to the X and Y axis.  Another tip, if you shift click the Z axis 
on the scale tool, you’ll be able to rapidly thicken your object without adjusting its height.  Sometimes it just feels better 
adjusting things on 2 axis at the same time – shift click the one you don’t want! 
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“Oh Snap” 

You can snap any transformation by holding down the Ctrl key.  Doing so, for example, when rotating will allow clean 15 
degree increments - - perfect to face something 90 degrees for example or 45 for a rocket ship. 

Ctrl + Transformations = Snappy Goodness. (to grid movements, angle rotation or scale percentages) 

Shift + S = Many snap options including some for cursor. 

Hugely Important Shortcuts (Outside the Gizmo/Manipulator): 

A = Select Nothing, Select All.  Good to start fresh sometimes.  

B = Box, or Rectangular Marquee selections. 

Shift + D = Duplicate Selection, then move in screen space. 

G = Grab, thus can use X,Y,Z to constrain to Axis. 

R = Rotate, thus can use X,Y,Z to constrain to Axis. 

S = Scale, thus can use X,Y,Z to constrain to Axis. 

X, Y and Z shortcuts are super handy when duplicating things (shift + D) because you can say have a sphere and hit shift + 
D,  to duplicate it, then hit Z to move it straight up.  Once you have two balls, one on top of the other, you can left click 
to commit changes, then hit S to scale it down.  Amazing! 

 

(playing in the snow will never be the same) 
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Edit Mode, aka ‘Modeling’ 

 

It is possible to edit objects on a per sub-object level.  Magic happens at this level.   “Object Mode” is good for scene 
composition, layout, animation etc but “Edit Mode” allows for limitless objects customization  in your sandbox of life, 
otherwise known as “Modeling”.  Edit Mode is dependent on what object you select.  That’s where the term “sub-
object” comes from, it’s as if you start transforming things within the object itself.   

What are sub-objects?  Components that make up an objects.  They are: 

Vertex: “Points in Space” 

 

Edge: An edge can only happen when you have to vertices which can connect – we have a line! 
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Face: Faces happen when we have three vertices connected.  Some would call it a triangle.   

 

Element (Object) : The whole thing!  Essentially it’s an island of connect vertices.  Therefore you can have two 
disconnected elements under one Object.  Good to know! 

 

Anyways, you can get into selecting, transforming, manipulating these components by hitting either Tab or by changing 
the mode selector to Edit Mode. 
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Above you can see the sub-object selector circled. This changes your sub-object mode or active compents.  You can 
choose to select and edit either vertices, edges or faces.  Just like our gizmo changer to the left, you can shift click more 
than one to have them all ready to select as you go.   

Handy Edge Selections: 

 

Loop = In edge selections, you can select an edge, go to Select > Edge Loop 

Ring = In edge selections, you can select an edge, go to Select > Edge Ring 

(Hot-Tip) Every awesome modeler is aware of the efficiency of converting selections.  To do so simply have you 
component selected and Ctrl click the sub-object mode you want to convert to.  For example converting a single edge 
selection to vertex enables you to rapidly select two verticies.  Amazing! Imagine if you select a edge loop or ring and did 
this!   

WARNING!  The double circled one above is important.  Some would call it “ignore back-facing” and it’s on by default.  
What that means is if you want to select an area with your box marquee (shortcut B), it will automatically ignore that 
which you cannot see.  That’s sometimes useful, other times very terrible and problematic.  Just something to be aware 
of.   

WARNING! WARNING! Don’t add objects in edit mode because they’ll be introduced at a sub-object level.  Bad idea. But 
sends the message home that you can have multi-element objects!   

Tab Key:  Toggles between Object Mode and Edit Mode. 

Modeling Basics 

Now that we know how to get into Edit Mode, let’s see what we can do within.   
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Adding Details: 

With modeling, it’s important to use the current complexity of your model as best you can before you add more 
complexity.  Push it as far as it can go before getting denser.  Example, you’re making a person, well push that single 
cube to a person size before you ‘divide’ or add more detail.  Nothing is worse than having a dense mesh that’s too crazy 
to control, and that’s not proportional from the get-go!   

The easiest way to add further mesh density is called Subdivide.  Try it when you have to edges side by side (or a ring 
selection) It is found under Mesh > Edges > SubDivide.  It will divide and conquer.  

Another handy tool -> Loop Cut and Slide This single tool will add complete loops (essentially subdividing a whole ring 
selection) before you release LMB, you can slide it too!   

Extrude = With a face select this will, as simply put as possible, extrude the face with supporting faces from bordering 
edges. 

Create Face aka Capping Hole etc.  If, by chance, you’ve deleted a face having an open hole in your mesh you can select 
the bordering verticies and use Mesh > Face > Make Faces/Edge (shortcut F).  If you have to verts selected, we’ll create 
an edge.  If you have three, you’ll create a triangle (face).  4, a quad etc. 

(Hot-Tip) Could be considered impossible to comprehend at this time, a good mesh or model is composed primarily of 
“quads” aka four sided faces.  Triangles are moderately acceptable and 5 + sided faces (aka ngons)  are taboo unless 
they are perfectly flat (like a top of a cylinder for example.  To learn more about this, research CG Topology with Google. 

Removing Details: 

Delete Key (duh)  But be careful, there’s a lot of different components you can remove and some don’t give the cleanest 
result.  You may need to undo surprises. 

Merge = Found in your tool shelf in the 3D view (shortcut T), this handy button combines vertices.  Most common is to 
‘merge at center’ which averages the locations of combination. 

Handy Edit Mode Tricks: 

A nice tool is the Edge Slide.  Especially on a complete edge loop selection (that’s why it is important to have mostly 
quads), you can shift an edge up or down while constrained to a face, hence sliding!  

Smoothing.  You can smooth that ‘facetted’ look by hitting the Smooth shading button in the Tool Panel (shortcut T). 
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Moving Components on their Local Axis aka ‘Normals’ 

In the image below, you can see every face and vertex has a line point out.  These lines, called normals, are 
perpendicular to the face angles and are an average of each face’s angle.  You can actually move vertices, faces and 
edges on their normals by use Local Reference coordinates! Super handy for fattening up an object or thickening a 
cylinder etc. 

 

The cool shortcut ‘O’ 

You can push O while in Edit Mode to enable Proportional Editing.  This allows you to have a greater influence on your 
transformations via something called a “soft selection”  try moving some verts with O turned on to see how you can 
handle denser mesh manipulations! 

 

 

Rigging 
The best way to learn the most complicated 3D software (3D Studio Max, Maya, Blender etc) is to Rig a character. 
Rigging a character entails using some of the most complex systems  and object classes in your chosen software.  Rigging 
is the setting up models/geometry/meshes to be animatable.  For example, can your character bend his arm?  Does your 
car’s wheels turn?  Does your jet’s landing gear pivot correctly? 
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This topic is vast and complex, but to begin we can start with hierarchy!  “Child to Parent” is the rule.  You have a cube 
and sphere in a scene.  If you want the cube to “inherit” the sphere’s transformations, (such as  when the sphere 
rotates, the cube rotates around it) all you have to do is select the cube first (CHILD) then hold down shift to add the 
Sphere (PARENT) to selection and finally hit Ctrl+P.  That’s it!  The cube can still be animated, transformed etc, but 
anything done to the sphere will be inherited by the cube.   

That’s a pretty simple example.  Another one would be if you wanted to make a 3D hand out of tubes or something.  You 
have all the tubes in place resembling a hand with gaps for the joints.  Remembering the “Child to Parent” rule, you 
would start by selecting the tips, going down the finger, one at a time, and then linking/parenting the finger to the palm 
and the palm to the forearm and the forearm to the bicep and so on!  You rotate the wrist and who hand/fingers combo 
moves with it!   

Summary = “Child to Parent”, Select Child, Shift Select Parent and hit Ctrl + P 

Un-parenting something?  Alt + P 
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To recap, remember to parent all the bits of your characters together.  Once they can move as one, around the correct 
pivots, it’s time to animate! 

(Hot-Tip) It’s good to rotate objects in Local Reference Coord’ upon fixing their pivots, you can see how the gizmo on 
that top robot arm link is ready to twist and turn all based on the earlier arm rotations. Enjoy! 

 

Animation 

Personally my favorite part.  How does it work?  Remember our notes on how a point has 3D coordinates or a location in 
space?  Well animation remembers such locations and can blend, or move, or as nerds call it,  “interpolate” these 
locations over time.   

Background:  Think of those page flipping cartoons.  It turns out all film is based on the same principle of juxtaposed 
images in a sequence.  What this means is that when you watch TV, you’re actually watching a series of “still images” 
rapidly flipping by.  Matter of fact, most TVs run at “24 frames a second”. Another visual reference would be a reel of 
film, it’s just still frames flying through the projector. Most video cameras take 24 frames of footage per second.  A 
claymation artist would cut that down and do say 12-15 frames a second.  That means for every minute of footage in 
your favorite Wallace &  Gromit episode, the patient animators had to do 900 individual poses!  Wow…. 

Timeline: 

Blender has a timeline, by default it’s located at the bottom of your screen.  You can slide, or “scrub” time by holding 
down the right mouse button and dragging.  You’ll be able to see what frame you are on by the number on the bottom 
left of your 3D view – initially at (1).   

To animate, what you do is tell Blender to remember an object’s transformations (move/rotate/scale) etc at a specific 
frame number  and then change your object and punch in those transformation on the timeline as well.  To begin, go 
back to frame one, select an object, hit the shortcut I which will ask you which transforms you want to remember.  More 
often than not, you would want all three – move/rotate/scale, so for Blender to remember all three (LocRotScale) you 
can us the shortcut I then, the number 6.  That’s it!  To set a key, you need to select an object at the specific frame and 
hit I + 6. 

Therefore, you need to move your time forward, right click drag in timeline, then move the object and or rotate and or 
scale to your liking – a new pose!  Then before moving the timeline again (you’d loose your new pose if you did) you’ll 
have to hit I + 6.  Popcorn and scrubbing the timeline!   

Matt’s Words of Wisdom:  The easiest way to animate characters is “pose to pose”.  This means keying your entire 
character on all LocRotScale, on every object or animatable thing, even if nothing was in fact changed.  The reason we 
“stack our key frames” like this is so we don’t get any weird overshoots haunting us from a key we added before another 
key.  Stamping out full character keys ensures success initially.  One your scene looks pretty well roughed in 100%, then 
you can break the stacks apart and start offsetting things and have settles, delays, jitters, overshoots – you name it!  
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Another benefit to having stacked keys is in our ability to quickly shift timing of our poses – you just have to move the 
entire keyed pose in the dope sheet. 

 

The timeline, aforementioned, is used to scrub our time to view our animation.  The  other most blatant feature is the 
range and frame # settings which adjusts the start and end time of your animation.  This can come in use when looping 
animations, you don’t want to wait for it to restart a year from now right?   

Timeline Shortcuts: 

Alt + A = Play the animation! (will loop set range) 

Esc Key = Stop Animation. 

Dope Sheet: 

 

Our Dope Sheet is a way of viewing our keys over time per object.  We can use the dope sheet to adjust our timing by 
making poses longer, stretching them apart, or making thinks quick and snappy, bringing them closer together. You can 
also quickly create “holds” by duplicating a pose and having it last for some frames.   

Summary: As the image above says, use this to quickly select and adjust stacked keys, you’ll have to turn it on initially.  
Shortcuts still apply here, you can duplicate a pose by shift+d, you can use B for box marquee and you can drag to adjust 
timing or re-arrange poses!  Awesome. 

(Hot Tip)  You can easily make looping animations by duplicating the start pose (everything keyed right?  All character 
objects, LocRotScale right???) then putting the pose at the last frame, actually the frame after the last frame in your 
animation range.   

Dope Sheet Shortcuts: 
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A = select all / deselect , deselect is really only used for this shortcut 

B = Box Marquee, excellent for selecting more than one pose at a time, this used on the Summary Line is most handy of 
all!   

G = Grab and Move selection, just live move in 3D view, Blender’s shortcuts work across many panels 

Shift + D = Duplicate Keys or Pose.  Once again, in conjunction with the Summary Line, one can easily add “holds” for 
dramatic effect in their animation, especially at the blocking-in stages.   

Another Honorable Mention:  The NLA Editor This panel allows for some “action strips” which is a step up from out 
Dope Sheet per key/pose editing.  Later, you could look into the NLA editor to create “strips of action” or a segment of 
collected poses to fling around your timeline.  I wouldn’t worry about this panel so soon.  It could come in use if I were 
to import/merge/append all your classmate’s character animations in one file.  I could then take each character’s action 
strips and offset them so each character breathes life one after another and not all together at frame 01. 

The Beloved Function Curve Editor / Spaghetti Monster 

v 

Just giving her an honorable mention for now.  This panel allows us to actually see what we talked about regarding 
“interpolating” from one location or transformation to another. The lines that connect the dots are what are computer 
does to blend transformations from one point to another.  Essentially time runs across the X and the value of our 
transforms run up and down the Y.  When you get to Physics class in highschool, your teacher would call this a 
velocity/time graph – I call it the Spaghetti Monster….  Anyways, another tip is that our speed is our slope of the line.  So 
if something’s super steep, it’ll be moving really fast!  In an animation studio, playing with spaghetti normally comes at 
the end of your animation process, when your poses are nailed, and you’ve added keys to break the poses down, you 
rock out here to add the final subtle changes such as overshoots (the line goes over the point) and ease-ins (steepness 
mellows out nearing point, slowing into essentially) and ease-outs (a mellow and gradual acceleration out of a point, so 
mellow to steep as it gets going).  Amazing! 
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Materials 
The simplest way to imagine an object material in computer graphics is to consider it a material group.   

Material/Shader Group: 

• Diffuse Color or Diffuse Texture (such as bricks, or a starry background etc) 

• Specular = shine properties.  Is our material shiny like plastic and chrome?  Or is it flat like a matte finish? 

• Bump = Materials can actually display surface changes that only interacts with light.  New on the scene is a 
‘Normal Map’ which enables a simple mesh to appear as a complicated one;  Doom 3 showcased this for 
example.   

• Type of Shader?  Lambert/Blinn etc  Blender splits these up per property.  You could have a Lambert diffuse and 
a Blinn Spec Shader.  Most often it’s the way specularity is treated. 
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Applying Materials to objects requires you to do a test render.  To do so simply hit F12.  By default it will create 
an image from your in-scene camera.  Feel free to move/rotate for the right angle(s). 

You can assign more than one material per object.  For example, you can select specific faces and assign a second 
material to them while have the rest of the object  remains unchanged. To do so, using the + sign button (stands for add 
new material slot) above where I wrote “Named Material = Good” in the image above.  Upon hitting that plus sign, you 
will now have two material “slots” to contend with.  Depending on what material slot you have selected, you can add or 
adjust the material within.  If you want to apply a material slot to a specific selection, simple enter “Edit Mode” (Tab) 
and hit the assign button that magically appears in the material editor panel! 

See below for what buttons to push once you have your faces select, ie the eyes or the mouth surface: 



YourCreativeMentor.com YCM2011-Blender2.56 

 

©Copyright YourCreatveMentor.com  – All Rights Reserved  (pg 25/30)  

 

#1 Select the faces you want in edit mode.  #2 Add a new Material Slot.  #3 A new slot with have the same material 
copied over, here you want to push the add sign to create a new material in the slot. #4 You Definitely want to rename it 
#5 You probably want to assign it your face selection #6 You can change the diffuse color and away you go!! 

 Be aware that any change you make to a material will affect your scene’s object’s appearances – this is why it is 
important to name things properly and apply materials accordingly.  GIVE EVERYTHING A NAME.   

(Hot-Tip) You can preview your lighting and some texturing by using: 

 

 

Lights, Cameras and Information! (about them) 
Lights and Cameras – just add them and hit F12 to Render a still image from the camera.  Of course you will have to 
refine your scene’s composition.  Which camera angle works best for what you’re trying to communicate?  Multiple 
Light Setup?  Make sure you nail a single light first before you add another.   

In the image below, which I used for the materials section, you can see I have three lights and camera.  Each light can 
have its own intensity, color and shadow settings.  The camera, it just takes our picture (render). 
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The options circled about are really all you need.  They are pretty self explanatory.  In Lights you can change the type 
which has different results (test render to see them, point your camera in the right direction!).  You can change the light 
color – orangey sunset?  You can change the light energy or intensity, you can enable/disable shadows and you can even 
choose the shadow color.  Did you know that most shadows are not black but reflect the atmosphere’s color?  Therefore 
adding a tinge of blue to your shadows adds extra realism. 

Camera Settings – The angle is most interesting you can slide it back and forth to adjust your “virtual lens”.   

Remember to test render constantly by hitting F12 to see the final result.  You can hit Esc to exit back to Blender.  Also, 
to view through your camera in viewport the shortcut is Numpad’s 0 key.   

(Hot-Tip) You can preview your lighting and some texturing by using textured viewport shading (see below): 

  

Rendering 
F12! Hit that and what your camera sees will be created!  Rendering is required for final work, to show it off be it either 
a still photo or an animated sequence.  Rendering takes everything from our scene into account: Lights, Cameras, 
Materials, Textures, Geometry, and if need be, our animation sequence. 

Rendering is considered very ‘resource intensive’ for your computer.  Studios are known to have render farms, or rooms 
and even office floors filled with computers just crunching frames of animation.  It’s important to not waste your 
learning time and render something complicated and slowly with little visual pay-off.  Rendering an animation at 
800x600 (screen size/resolution) would be a bit of an overkill for this course.  Maybe 400x300 would be most efficient to 
see what you’ve created.   

The reason rendering takes so long is because it converts your ‘real-time’ workspace data to a still image, essentially 
taking a picture.  We’ll be using Blender’s default renderer although software includes different rendering engines to 
produce different results.  Beyond the software’s default renderer, a very popular one is called ‘Mental Ray’.  Pixare 
created their very own called “RenderMan”.  A friend of mine recommended Lux Renderer http://www.luxrender.net/ 
to use in this course, but might be over kill in this week long course (at home though?  highly recommend it!). 

Below is an image outlining how to render with Blender’s default renderer: 

http://www.luxrender.net/�
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(Hot-Tip) Make sure you adjust the start and end time of your animate, aka “The Range” as outlined in the 
Animation/Timeline section.  You do not want to sit and render 500 frames of doing nothing – trust me, I’ve done it. 

(Hot-Tip #2 + A Warning)  In the image above, where it saves to know where you’re saving your render – it’s recommend 
to click the little folder button to ‘Save As’ and actually name your output.  You do not want to overwrite your previous 
works, especially the final ones!  Remember our conversation on incremental saving/naming, it applies to rendering too. 
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Modifiers 
Modifiers are a “procedural” way of editing objects.  A Modifier changes your object or select depending on what you 
choose.  The beauty  is that you can layer modifiers, turn them on and off, re-order and apply them which “bakes” the 
modifications to your selection.  The layering is most useful, like layers of a cake you can preserve the great taste and 
revisit! 

My favorite modifiers are: 

Sub Division Surface: This bad boy sub-divides (like in edit mode) your entire mesh.  Since it’s a modifier it can be turned 
on and off allowing to smooth out your ridiculously blocky models!  Beware though, if you turn the steps/levels up too 
high, your computer may considerably slow down!   

Mirror:  Play with this when modeling a symmetrical model, be it a vehicle to a character.  Watch which axis you mirror 
over, it probably would be the X if you modeled the front of your character looking down the Y.  If there’s a gap between 
the mirror, you can adjust your object’s pivot or ‘origin’ to fix it.  Also, you can adjust the merge weight which will weld 
the center polygons together so there’s no overlap and a seamless model. 

Build:  This fancy modifier will take your object and build it, face by face.  Make sure you have enough polygons or faces 
to make it look interesting and gradual.  Preferably, you can add this modifier underneath the SubDivision one for a neat 
animated effect.  Try the randomize option to make a Tron-like effect!  Don’t forget to scrub the timeline. 

 

Appending & Linking Blender Files 
You can take the contents of one Blender file and append, or add them on to another Blender file.  You can also link 
Blender files which data is shared and transferred – therefore the changed made in a linked Blender will occur in your 
Blender scene in which has received the link.   

For the summer camp, I will probably ‘append’ everyone’s work into a single scene and offset the animations for a 
collective render!  Good luck!   

Link/Append is found under the File menu of Blender. 
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Fun With Sculpty  

(essentially like unlimited nutty putty - IT IS POSSIBLE) 

 

Sculpting, using insane mesh density is now possible and part of most studio’s workflows.  The pioneers in this field are 
the makers of Z-Brush, called Pixologic.  Check them out! http://pixologic.com 

Create a cube – Add > Cube. 

Open the Modifier Tab, Add a Multi-Res Modifier.   

Hit SubDivide and test performance by orbiting.  I found level 7 was greatest before computer got slow. 

Enter Sculpt Mode.  Notice the Tool Shelf changed.  Here play with the variety of tools on your subdivided mesh. 

Workflow advice:  It’s better to rough everything in, starting from massive and obvious details and working towards 
smaller details – remember BIG TO SMALL!  Therefore, it may help to lower your sculpt subdivision levels down initially 
to start sculpting on a lower resolution model.  Once you’ve pushed your model as far as it can, step up the division level 
and add as must detail and shape as that level can support! Repeat and you’ll have a nice foundation for sculpting either 
digitally (where the money’s at) or in clay!   
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